Possible memory leak

Ive been playing beammp on the same setup for about 6 months absolutley no issues. All of a sudden when im playing gridmap on the default server my frame rate will go from 100ish for about 3 minutes then suddenly drop to about 10 then quickly gets worse until it crashes. The whole thing happens in less than 10 secods from the first lag spike. I saw in the in game chat another user was experienceing the same exact issue as me out of the blue.

I also tested my pc with memtest, gpu artifact testing etc with perfect results. No thermal throttling. I should also note i had HWmonitor open and saw my ram usage go from 60 to 100 during the lag spike. This happens everytime i try to play. I get no error meggage other than windows saying not responding.

Edit: Tried again today hoping to get more than 5 min of game time in and same issue, got this error code BeamNG.drive 0xC0000409 STATUS_STACK_BUFFER_OVERRUN

1 Like

Hi Kristopaquio,

From what i have heard, this is a problem with the game itself.
Some theories that the sound engine is to blame since the latest update.
We are aware of the issue, but as I say, not sure we can do anything about it until the BeamNG devs fix the issue.
Fingers crossed it gets fixed soon!



I’ve got the same issue, and I believe all of us do. These two topics are related to the same thing:
Sudden lag and audio cracking - Support - BeamMP
Low fps on High-End computer - Support / Client Support - BeamMP

I also crashed and got this same error code once. Moments before that happened, I heard my CPU fan starting to spin like crazy (indicates CPU usage has dramatically increased, and temperatures with it) and the game became incredibly laggy, GPU usage dropped to 5%.

@daveywaveyHD, are you absolutely certain the issue lies within the game itself and not BeamMP? Cause according to BeamNG’s official known issues list, “BeamMP may cause instabilities and issues with the game and game UI.”

Hi DilyanD,

These are the threads on the BeamNG forums relating to the issue. Apparently the BeamNG devs are looking into this, but not much information being shared as to what exactly is causing the issue.

Please note the one below has an inaccurate title, but the rest of the thread is related.