Backend system refused server! Check your AuthKey

Today I generated a new key on this known site: So far so good. Added the key as always in the cfg form the server. But the server is refusing my key: “[12/12/2020 19:27:54] [ERROR] Backend system refused server! Check your AuthKey”.

What could be the reason? Was there an update on the beamng-mp site and hence no keys accepted?
The server simply won’t start because of this error.

Any help would be appreciated.

@Titch & @Charles:

From my point of view you can close this case - or keep that as information source for someone who get the same error while using wine-6.0-rc1.
And thank you both for your answers & suggestions. :slight_smile:


Good to know!
Thank you for your information and investigation.


Yes, if you install “wine-6.0-rc1” on CentOS 8 (probably on every distro), then you’ll get this error:
“Backend system refused server! Check your AuthKey”
Earlier version of wine work (5.1 and earlier), the key is “recognized” or accepted and the server runs without any issues.
I thought maybe you know what the reason could be…
If I have to wait for the RTM of wine 6.0 (as currently “rc1”) - no problem, probably that this error will not occur in the stable version of “wine 6.0”

So Wine turned out to be the issue just to confirm?

1 Like

After installing of wine-6.0-rc1:

[13/12/2020 11:38:43] [ERROR] Backend system refused server! Check your AuthKey

Which means: I have to downgrade the installed version of wine on my machine…
Now it’s obviously clear why the key cannot be accepted.

If somebody had maybe similar issue and can provide solution, pls share.
If not - then I guess this case / issue can be put “ad acta”.

After restarting it didn’t work, the same issue.
Worth to mention is that wine version was: “wine-6.0-rc1”
What I did:
Reinstall my CentOS (I’m using Putty - SSH to connect to my machine) and installed wine from CentOS 8 repo.
“wine BeamMP-Server.exe” worked, auth key recognized, server started. All OK.
Now is interesting if the “wine release candidate 1” was causing this non-accepting of my key.
So now I removed (working wine) from the machine and started again the installation of „wine-6.0-rc1".
After installing of some deps, “./configure --enable-win64” was successful, make is still in progress…
Will see if the issue (the key not recognized) will occur again…
Let you all know then about outcome…

ok, thx - will try that

@EasyGaming This has happened to other people before. The fix (although very strange) is just to shutdown the server, and restart it.

@Charles: thx for your answer.

Unfortunately, this is not the reason.
No spaces and quotation marks have been set.
I used that some days ago and that worked.
My server is a linux, using wine64, that worked until today.
But today – during the day - I tried to create new key and the site beamng-mp was not reachable due to some update on the site.
Then I tried later today and was able to create a key but the key is not accepted by the server.
The only reason I can imagine is that I changed my connection to another user in: Einstellungen | Patreon (Patreon settings for Discord, under apps).
Could that be the reason?

@EasyGaming Make sure that the key is correct in within the “quotation marks” AND is has no spaces

1 Like

I know you might never check this, because this post was created on december

but man, thank you, i missed one space :))))