BeamMP mod keeps deleting its self! What can i do?

If i start the launcher the mod is been created.
After i launch the game the mod delets itself.

Did you ever find a solution? I have the same problem

Are you able to join other servers?

IF so then there is an issue with your server somewhere most likely.
In either case can you upload your launcher.log and beamng.log files. After the error happens please close the game by clicking quit and letting it close gracefully so that it writes the log files. Thank you

@charles Thanks for the quick reply i tried everything and it doesent work i reinstalled it and it doesent work yesterday it all just worked fine until i tried to connect my own server is it possible it is a failure with the server launcher?

The mod shouldn’t and doesn’t delete itself. If you see in the mods folder, and when you load into BeamMP and you dont see it, here are some things to make sure you are doing correctly

-Make sure you are starting the launcher when playing BeamMP
-Make sure your Antivirus and Windows Defender (in rare cases) is allowing BeamMP
-Make sure your BeamMP Mods folder and BeamMP launcher has sufficient permissions to read and write files to your PC
-Try to active BeamMP while in the main menu (activate it in the Repo)