BeamMP Modded server issues

Hi, I’ve been trying to run a modded server with some issues I don’t see anyone else having. I’ve opened port 30814 in both my pfSense router (Built my self, not a pre-built by Netgate) and Windows Firewall just in case. No other security software is installed on my server. We’re running 66 mods of random parts and cars, 1 modded map that we’ll switch out each time, and I’ve tried with and without a modded map. I only thought of adding maps in manually because of this issue I’m experiencing, ideally I’d just have everything in the clients folder on the server and not worry about it.

The issue I’m having is that the first time you join the server it downloads the mods without issues, either for me or for anyone connecting remotely, usually the first time everyone can join. But, if you leave and try to connect again, the client will get stuck at “Loading resource 1/66…” and the server CMD output sits at “Sending client info”. The only way to resolve this is to clear your resources folder and let it download the mods again. I can not add the mods beforehand either due to this. Local or remote connections all have this issue.

Otherwise, anyone can play on the server for hours but the second connection to the server always has this issue. But, I did start noticing that a few randoms tried to join the server and their downloads would freeze randomly about halfway through the 66 mods on the server. By freeze I mean the CMD output will just sit at the last file they requested until they force a disconnect.

My server is running 2 other game servers as well but I can’t see how this could be affecting it. 7 Days to Die and Terraria are the 2 other servers running with minimal players on them. This server also acts as an Emby (Plex alternative) and file server.

Our internet speeds are:
900-975 Mbps down
35-41 Mbps up

My server specs are as follows:

CPU: Ryzen 3950X locked @ 4.3Ghz
Motherboard: X570 Asus Crosshair VIII Hero
RAM: 4 x 16GB kit @ 3600Mhz, this kit is on the QVL for my motherboard
Drive BeamMP is installed on (Not on the OS drive): M.2 256GB Pioneer NVME SSD
PSU: 850W EVGA G3 80+ Gold

Please let me know if there’s any other information I can provide and I really hope I’ve just made a silly mistake. Thank you in advance!

Easy fix delete the folder the launcher is in (aka the entire beammp-launcher folder) reinstall it and run it

We are also encountering this one and looking into it still. We will try to fix this!

1 Like

Hi @Titch2000 , I made a few odd discoveries last night thanks to a few comments made by Anon in the Discord server. I’m starting to think this might be a BeamNG issue instead.

Anyone joining remotely no longer has an issues, the 0.49 server update from yesterday appears to have solved that issue as far as I can tell, I did fresh install the server as well. The other issue of remote connections having trouble connecting seems to be linked to the modded map’s name. Anon mentioned the names were case sensitive, I figured you should follow the capitalization of the “levels” name in the folder hierarchy of the modded map. Making sure everything was lowercase seems to have fixed that issue in particular. Remote players can always join and never have to download their mods again, only the first time they join (even if they have the mods installed).

I do still have trouble joining and my process to join the server has to be; 1. Clear the Resources folder in BeamMP. 2. Clear the BeamNG user cache under support tools in their launcher. If I do not perform these steps each time I join, I will always sit at loading the first resource indefinitely. This appears to be an issue whether I join my own server or someone else’s and sounds like a BeamNG issue and not a BeamMP one. Do you have any knowledge of an issue like this or any potential fix you might know of?

Sorry for the trouble and thank you in advance for any info you might have!

It does seem to be a very odd one that much i can say for sure. We will need @Anonymous275 to help you with this one unfortunately. Sorry

Hi, @Titch2000 thank you for the response!

Hopefully Anon can answer the rest of my issues but, just to clarify, the downloading of mods isn’t an issue. Once any client has the mods, they will sit forever at loading the first resource. I can wait 5 minutes or an hour, it will never progress past the the first resource. The first connection is fine, every time after will fail.

Also, I have noticed that a few moderators and helpers have suggested players get “mod packs” downloaded ahead of time to avoid downloading from servers constantly. We decided to do this ahead of time but, everyone that joins downloads the mods anyways or sits at loading the first resource indefinitely. I’m assuming I have some kind of isolated issue as I’m imagining everyone is not clearing all their mods out every time they join a server. I don’t see anyone else complaining about this issue in particular so I’m figuring it’s something with my setup or particular network settings possibly.

Thank you in advance!

Hello @Benton1234 It is possible that the issue you are experiencing is due to the game loading the mods in. It has to do this one by one to ensure that they are picked up by the games mod system correctly. With the large amount of mods and the possible size of them this could be why you are experiencing the issue when you try to join back. As for the other bits i would have to wait for @Anonymous275 to reply as this would his area of information.