Cannot join my own server, invalid zip file

I’m hosting my own Beam MP server with a couple of automation cars and a modded map. When I try to join without mods there is no problem and I can play along just fine, but when there is a modded map or automation mod in it I can’t. My friend, on the other hand, can join with mods without any problems.

When I add mods to the server I put them in resources/client (as ZIP). When I add modded maps I do the same as described above, only I also look in /levels/(mapname) for the name of the map. I then put this name in the server config file. I have the purchased version of both automation and beam ng.
Anyone who can help me with this? By the way, I tried to join both with direct connect and via the server list. Photo of error shown below, sorry for bad english i’m from the Netherlands :wink:

Hello
You are using one for the rare maps that are named differently then 99% of modded maps. Crash hard is a .mis map AND or it is a map that has a name that isn’t “crashhard2.0” but I will explain .mis maps first to see if that solves your issue.

Instead of putting “/levels/mapname/info.json” crashhard2.0 is a .mis so it should be structured like this in the config.toml “/levels/mapname/mapname.mis

Make sure everything is lowercase even if the map name isnt

Hello,
First of all thanks for your answer. In the server config I have at map:
Map = ‘/levels/racetrack/racetrack.mis’. But when I connect directly now I still get an error even though the mod is also present in the client. But this is not the main problem to be solved, rather I would like my automation cars to work in beam. Any idea how i can solve that? When I try to direct connect I get the same error as in the picture and beam just keeps loading without doing anything else.

The weird thing is that my friend can always connect to the server without any problems while i (host) keep having problems when there are automation mods in it

This could be another weird problem with trying to download mods from yourself. Delete the crash hard map from your client side beammp folder (right click beammp launcher shortcut on your desktop > open file location > resources > delete crash hard) then copy crash hard map that is in your server resources (resources > client) into your BeamMP resources folder we just deleted it from. Very weird issue but this has fixed it before :slight_smile:

Onfurther inspection, I have figured our the CrashHard 2.0 is NOT and .mis map, it just has a different name then “crash hard 2.0”

So you map line in the config.toml should be ‘/levels/racetrack/info.json’

I just changed the map to a gridmap v2 and without mods I can join the server just fine, so that’s not the issue. Only if I only add 1 automation mod from myself or from a friend, I can no longer join but my friend can. Any idea how I can solve this? Thank you very much in advance!