Cant connect to my server

I recently made a server and there are no errors in the server module but in the launcher module it says cant connect error code 10060, my friends cant connect either. I am hosting the server and added a port forward through my internet port 30814, I allowed this port through the firewall. What am I doing wrong? It shows up on the public server list

make sure you port forward the port 30814 as UDP and TCP in your router settings (10060 means port forwarding issue) also make sure that if you are joining and hosting the server from the same computer that you are direct connecting to your server with IP: and port: 30814

In my router settings port 30814 is set to both and both are allowed, and what do you mean direct connect from how would my friends connect

Do I have to be on the server for them to connect? I tried having him connect yesterday while I wasnt on the server and it would just fail to connect him

As the host (hosting the server and playing on it with the same computer) you have to join with direct connect. everyone else can join it normally

if you are still getting code 10060 then it is still a port forwarding issue. make sure you have also port forwarded 30814 to the correct internal IP (internal ip on the computer running the server)

that would be my ipv4 correct?

my public ipv4 or the one i find in cmd? Because the port is sharing the one i found in ipconfig

You need the public ipv4, just google whatsmyip

No, that is your public IP, you will need your internal IP

Your internal ip is the one you find in CMD with ipconfig

I used my internal ip and public ip and neither works, it worked a little yesterday on the public id but now it doesnt work, i can join but theres no errors. other players cant

When I ran the server yesterday, it worked on my public ip. I cant seem to set up a port forward through my public ip but my private ip has a port setup for 30814 both TCP and UDp. Don’t really know what the issue is. Is it normal for my ipv4 and public ipv4 to be different?

when i log in to my router it says the computer im hosting the server on has a reserved ip, would switching it to DCHP fix this

Alright, I tried everything and for some reason my xfinity xfi router will not let me open a port. I used port checker to see if the port is open and it wont open… Should I call the provider

Ahh you have Xfinity!
You will need to go into the security section and disable protection? It has been awhile for me since I have done this myself but you will need to disable a security feature for Xfinity to allow port forward (very ■■■■ on their part for not disclosing this at all but it is what it is)