Cant join anny modded servers

every time I try to join any kind of modded server it comes up with invalid zip file.
I have tried to re-install beammp and beamng and still, nothing seems to work.


Same, plz help!

Having the same exact issue, on both my own hosted server and any other public server.

I am having same issue, except when it finishes downloading the mods some servers will just get stuck on the loading screen and crash the game, and in the servers that load AND say their mods failed the mods are completely fine and work as usual. Could somebody help us plz!

Anyone got a fix for this??

We fixed the problem!

We had tried to put the map-string in as /levels/carkour2/info.json.
This seems to not alwways be correct and there is not much info out there about it.

We used this string instead and the map booted and works for us!

I fixed this by going into settings>multiplayer and turning on the Experimental mod loading option. Hope this helps.

Does anyone have a fix for this yet? I tried turning on experimental mod loading option and it still gets stuck on loading screen. Very frustrating. I have had beamng for a day and wanted to try beammp but cannot get into any servers that look like fun.