Cant log in suggestion

Check to see if your email is in caps or not that’s what happened to me.

I Used my Username and worked first try

Yeah this is a issue at the moment, that it fails constantly. Its being looked at, but at the moment you cannot do anything more then to try again and again

I have not been able to login for days. I can log in as Guest and have no problem connecting to Servers and playing for hours. Frustrating as I’m am well-experienced mainframe online and Windows developer. Yes I am running BeamMP as Administrator.

Earlier today I was getting ‘Invalid answers from authenticating servers’ with occasional ‘Bind failed error 10048’ and now getting “Login failed. Check your email/username & password”.

Is there a troubleshooting guide to debug?

That your beammp account either by email or username fails to to login is weird. In case you havent played beammp for a while, see if you verified your beammp account, because that was a change that got made maybe a month or two ago.

Anyway, the issue lies within the backend properly broadcasting the generated keys to the different sub systems. I was told and i hope i dont convey this wrong, that its a db issue and error cases, that comes from that, that arent properly handled. When you login with your credentials you should receive a private and public key, that private is saved to the key file (in your beammp installation), and used for the next auto login. The public is send to any game server you may join, where the game server then sends that public key to the backend to verify it.

Those two instances, the client side login and the server side verification, are to my knowledge, handled by two different systems of the backend that at the moment dont communicate well, which leads to code 500 responses from the backend very often.

Running the launcher or game as admin doesnt change that, as a typical end user os installation doesnt have internet access restrictions. The 10048 error is a socket error. The launcher listens to 4444 tcp and later 4445 tcp, which is where the lua mod connects to. Any software running on your machine, that may just be a earlier instance of the launcher, that already bind that port, will prevent the fresh spawned launcher process to also bind those ports

Thank you Neverless for the explanations. I will look into this in the morning and hopefully lead to resolving the issue.

You can mark my issue RESOLVED! Thank you again Neverless. I tried everything and I finally noticed I had 2 listings in my Google password manager account. One was for www.BeamNG.com with the last password I had changed to and the other was for BeamMP with the original password I had set up (thought to be now obsolete). I tried signing in again (prior to v29 update) using the BeamMP password and success! I was in Multiplayer and could see & connect to the servers! Good end of story.

Thats good, meanwhile the backend issues also have been resolved! :slight_smile: