controller with force feedback detected (Bug?)

I am experiencing a somewhat annoying bug that seems to be increased with Multiplayer. Every minute or so, I get a message “Controller with Force Feedback Detected”. When this happens, the game lags out, sometimes for 1s, other times for 5+s. Doesn’t seem like that big of a deal until you’re rock crawling and then lose steering and braking - plummeting to the bottom of the mountain!

I don’t have any other controllers connected. I do have a full VR setup (Index), Base Stations, etc. A bluetooth keyboard next to my rig and wireless mouse. I also noticed the mouse gives inputs when mapping controls - could it somehow be the mouse? Or the bluetooth keyboard connecting? I did test turning my bluetooth keyboard off though, and I still got the freezes. For what it’s worth, I tested BeamNG vanilla - no mods, no multiplayer - and this error message occurred once in a 3m period. In multiplayer mode on a vanilla server, it happened 6x in 3minutes.

Here’s a video example (youtube): http://somup.com/crnDc3DqUl

I’m running Fanatec CSW2.5, CS inverted pedals, CS Shifter, CS Handbrake. I wouldn’t say it makes the game unplayable, but when I’m crawling and the game pauses and loses connection to the wheel and pedals, I tend to fall down the mountainside!

If it helps - I’m running a 50ft USB extension to my simrig setup. Not sure if that somehow screws it up.

@alex-ita said in controller with force feedback detected (Bug?):

Not really… It doesn’t sync automatically the modifications the other players do to their vehicles. In order for you to see them correctly they would have to save the config and respawn the car with that config.

Thanks Alex!

Not really… It doesn’t sync automatically the modifications the other players do to their vehicles. In order for you to see them correctly they would have to save the config and respawn the car with that config.

Oh! Will unchecking the automatic parts sync mess up the multiplayer experience?

That happens when other players reload their cars, if you want to limit this you can go in the options and in the multiplayer tab uncheck the automatic parts sync.