[ERROR] (Core) bind failed with error: 10048

Has anyone seen this?

I have the same issue, i searched it up and it says that some program is using the same Port as BeamMP. No idea what Program causes it, or how to fix it.

Hi Filiupu and GuentherBasart, i think i got the solution for you because i just had it and i could solve it.

1st- Go to firewall advance security and in entry rules and exit rules check that Java™ SE is allowed, and same with BeamNG.(Has a green tick if allowed, if not is a prohibited signal) Right click,properties, and in the green arrows put allow connection.(As shown in the images below.)



2nd- When you have done that, uninstall BeamMP mod and restart your computer, when done that, install it again and check if works correctly.
Let me know if that worked out for you guys!

uh i dont got firewall advanced security

Every user in windows have it, you prob didnt check right.
Just go to control panel, type in search bar “Firewall of windows defender” , then on left hand side of the screen the penultimate option and thats it.
You have also some pictures so you can guide yourself.
1-

2-


3-

4-

IMPORTANT
Remember to go to inbound roules and outbound rules and check that the other things i said are allowed.
Good afternoon lads.

So I’m trying to figure out what I’m doing wrong, I cant seem to find Java™ SE in firewall advance security, so dose this mean I don’t have java or am I just looking in the wrong place?

Do not worry about it Torry, i investigated a bit more on this subject and java has almost any impact on Beam, is just a something that COULD affect in EXTREME rare cases (If u have hava SE, if you dont have it, forget it ).
Going back on the subject, just look for the BeamNg and check that is ok. Then unistall beammp and reinstall it, check that you only run one instance or it will give you back the same error.
Lemme know if that worked so i others like you can have some feedback to see if it works.

ok it worked, I double checked beamng and it was connected, then reinstalled beam MP and it worked, thanks for the help

I did what you said about reinstalling beammp but how do i select which instance to run?

You only should have 1, which is BeamMP. (And if you have server.beamMP is the same.)
I dont know really what you meant, but just is one launcher and run it only once a time, if you run it more than once will give you the same error.
Lemme know if is that what you wanted, if not rephrase it again so i can undestand it better.

Well every time I try to run it it gives me the same error. How do I get rid of the error? I tried uninstalling and reinstalling but it doesn’t help.

That error is caused by two apps connecting at the same time to the same port, or the apps are being blocked by the Firewall.
Did you do this?:
1)Open the restrictions on firewall (As is indicated in previous posts)
2)Reinstall it
3)(This one may be the rarest) Antivirus is blocking the connection to the network, this can be solved by creating a rule that allows it.
4)Run as an Administrator
5) Make sure only one instance is running at a time

**** NEEDLESS TO SAY *****
When you finish all changes in firewall , Reinstall apps or related, restart the computer. This allows that every 0 or 1 in windows is changed properly.

I did open all restrictions on the firewall but i have not restarted my computer. Maybe i can go back in to the firewall and make sure there are no restrictions and uninstall and reinstall then restart my computer. Is that correct? And what if i do all that and the error still occurs. What should I do then?

Yes that is correct. Reinstall, open the rules of firewall and antivirus if it is interfering and lastly restart.
Well first try that out, if it does not work maybe you are in an outdated version of the beamMP or and need to downgrade the current version of beamNg(shouldn’t be necessary).
Also didn’t mention if your windows is on 32-Bits or 64-bits.
We will work something out, just guide me through your steps.

Continuing the discussion from [ERROR] (Core) bind failed with error: 10048:

yea me to i have this problem :frowning:

Do i uninstall the launcher or the installer?

Launcher, but it is always optimal that you also delete the lnstaller. Sometimes the installer is slightly corrupted or outdated.
Cheers.

Read my posts, most likely help you out. Any issues you experience or arent properly adressed write them out, I may be able to help.

10048 indicates multiple copies of beamng/beammp launcher running. Easiest fix is to restart PC. Second way would be to open task manager and close all tasks related to beamng and beammp and try again.