Failed to communicate with the auth system!

This issue just started today.

Whenever i launch BeamMP the console looks fine and it loads up like usual, but when i log in, it says in red text “failed to communicate with auth system!”

This is what the console says:

[9/1/2021 15:24:13] [INFO] Attempting to authenticate…
[9/1/2021 15:24:18] [ERROR] Failed to communicate with the auth system!

happens when i try to register as guest aswell

Nvm! I resolved it.

If you having the same problem, try these things…

  • deleting the, “key” folder , like stated up above,
  • disable ANY blockers you have on whatever internet browser your using, an example of that would be, ADBlockPlus, which is what I had.
    I disabled that, restarted beammp, and logged in using my profile name, and it worked!
1 Like

I’m having the same problem, and I’ve tried to search for the, “key” folder in the BeamMP launcher folder. But I can’t find it, Is there anything else i might be able to try to fix this problem?

In the discord server theres a ‘Before You Ask’ section that guides you through the issue in the Console:

“I’m getting [FATAL] Invalid answer from authentication servers, please try again later!”

  1. Open the file location for the BeamMP Launcher.
  2. Delete the file named “key”.
  3. Relaunch the BeamMP Launcher.


If it’s not an issue fixed by running as admin and if the issue only happens sometimes, then it’s a known issue with the auth system that will be resolved in the next update

1 Like

@charles Running as admin didn’t work.

1 Like

При логине пишет Failed to communicate with the auth system!

Thanks. Running it in Administrator mode worked for me. idk why this wasn’t a problem before.

Try running the launcher as administrator, make sure that your Antivirus isnt blocking connection between the laucher and the game (allow beammp launcher in AV software)

Edit: was able to use guest account. still unable to log in with my BeamMP account