Game freezes+crashes while attempting to connect to a server

I’m trying to join a friend’s server via direct connect, IP address and Port are correct, he’s got only 6 mods installed, but for whatever reason, the game loads up until the last “square” on the loading screen before the whole game freezes. After a while it just crashes. I’ve already uninstalled and reinstalled, allowed anything related to BeamMP through my firewall, and nothing’s worked. I’m just at a loss right now.

Inserted pic to show where the game freezes+crashes

I have the same problem

Just got Beammp and got the same problem with the game crashing after a while

Heyo,

Does this happen for all servers?
Do bare in mind that if a custom map is loaded on the server that happens to be particularly large, it can take many minutes to load.

Dave

It happened with any server, regardless if it had a custom map or not, and another friend of mine had the same issue as well. We tried the waiting game to see if it’ll eventually load, but like I mentioned, the game just crashes and closes out.

But, what I found out is, both of us have a fairly large amount of mods installed into our games. I had the random thought of removing them all before I started MP. Turns out that was the trick. Did some testing with the mods left in, and yeah, seems like MP is trying to load into a server, but removing all that has solved my issue.

1 Like