Game freezes when trying to enter a server, crashes before the BeamNG icon fills up

I keep trying to enter a server in BeamMP and the game freezes before the BeamNG icon fills up, ive tried waiting and it just crashes. What should i do? I am new to BeamMP and im just trying to play the game.

Welcome to the game :slight_smile:
Can you try joining a official server and see if that works? Just want to see if this is caused by a mod of that server or if its a general issue in your game

Sure, i will try joining an official server and tell you the results :slightly_smiling_face:

Edit: I’ve tried to join an official BeamMP server and the game still freezes.

Alright in that case i will need to take a look at your game log to see what the potential error is.

  1. For that please replicate this again, then quit the game.
  2. Start the BeamNG launcher
  3. Click “Manage Userfolder”
  4. Click “Open in Explorer”
  5. In the opening new window will be a file called beamng.log

I need that file, it may contain errors that help figuring this out

I would be happy to share this, but the character limit doesnt let me copy+paste it into this reply, ive tried to drag the file in too but nothing works. Is it because im launching BeamMP? Am i supposed to launch BeamNG from Steam instead?

I have the same issue as well.