Getting error 10061

Hello, I am trying to set up for my LAN so that I can play beamng with my son. I have read and reread the instructions, following them closely. I have set up the config file with the key I received, I have put a port forwarding rule on my router, and allowed the game via windows defender firewall (inbound and outbound). I have spectrum internet, but have my own router connected to the modem, and do not use any 3rd party antivirus.


Each time I try to open BeamMP and click on multiplayer/direct connect/connect, I keep getting connection failed after about 10-15 seconds. On the launcher window, it reads “[ERROR] Client: connect failed! Error code: 10061” followed by two warnings of “Failed to close socket!”.

Also, when I attempt to use portchecktool (which I am doing with the BeamMP loaded) it is saying that “Problem! I could not see your service on xx on port (30814 ).
Reason: Connection timed out.”

I have been trying to research this for days, including here in the forums, but have yet to find anything suggested that would make it work. Please let me know if you have any suggestions. Thanks!

Hi there,

It’s not entirely evident from your post, but are you running the server? You need the server to be running (even if it’s a local connection) - if you run it on the computer that’s port forwarded you should be able to connect to it with the other computer using the external IP address (type what’s my ip address into google, and use that ip to connect using the other computer).

If ‘yes’ to the above, have you tried connecting with the other computer using the internal IP address?
open CMD and type ‘ipconfig’ and use the ipv4 address. I’m not sure this will work, but worth a shot.

That was a big help. Sadly, what I had thought was the server was actually the client-side. Once I started the server and then went to the client-side, I was able to connect just fine, and actually drive cars and such. Sadly, my son’s computer gets stuck in the loading screen after connecting to my computer/server, so we’re still not able to play together. Later on I’ll try to have him turn down his graphics settings and see if that helps. Do you have any other suggestions as to why he would get stuck on the loading screen when connecting to my server?

Glad we got some of the problem sorted! Regarding getting stuck at the loading screen, does the server console say anything? Maybe try setting the server to gridmap first, something quick to load and not very intensive just so we can rule out hardware issues.

Thanks,
Dave

I had a chance to sit down with both computers this morning, and had the same issue at first. The server readout said that my son’s computer was connected and seemed fine on that end. On my second try I turned down his graphics settings just in case. I watched task manager on his computer as well, and noticed that his RAM was almost fully in use before BeamNG and therefore BeamMP failed and shutdown. On a hunch, I disabled all of his mods (157!) for the third try. Lol between making his own cars and downloading others he’s been busy. Anyway, after disabling the mods it all works fine now. Thanks again for responding!
Gwen

1 Like