Getting stuck trying to load into modded servers

So on BeamMp i can join servers with zero mods but when i try to join a server with mods it will download 1 or 2 mods, give me a zip invalid error and then get stuck on the one mod and nothing happens. I have been trying trying to fix this for the passed 4 days and nothing. Its weird i was able to join before and now cant. Ive tried completely uninstalling everything and it still doesnt work. just can only join servers with no mods

1 Like

I’m having the same problem. This never used to happen, now I can only join servers with no mods like the “Official” servers. It won’t show the mods downloading percentage, it will just say 1/whatever number of mods there are. Then it gives me the “Error in ModManager - Invalid zip”

I also tend to get the ‘invalid zip file’ error pop up, but it seems to be a meaningless warning, as everything loads as it should. The pause after downloading some of the zips might just be the game activating the newly downloaded mods, which can take a minute or two if it’s a custom map.

Next time you get the errors, just persist with the connecting and hopefully it will connect.

1 Like

I’m getting the same issue. I used to be able to load to all of the servers even with a ton of mods without a problem but now I can’t even play servers with even a single mod. It just downloads the file and says loading that particular mod forever. I’ve already wasted hours loading on various servers with mods and it’s getting boring.

Everywhere I look and everyone I ask just keep saying delete the mod from the resources but that does nothing, the issue just comes again. I even tried deleting Beam.NG itself and deleting BeamMP but it does nothing.

You can try to enable the “experimental mod loading” option in Settings > Multiplayer