I can see people but people cant see me

I can load into a server but ping and players have a ? next to them and when i spawn in a car it spawns 2 duplicates and fixes the ? to the actual number of players and ping but i can see people and people cant see me and whenever i interact with them like crashing its like im not even there and they continue.I had a friend join my lobby and he cant see my name tag or anything.

Me too, is there anything to solve it?

Same problem here. I made sure all the UI Apps were on and my discord name does not contain any special characters.
Edit: I do see pings, and player counts, people can see me in player list and ping as well.

Same here. I’ve had this problem for months.

First I have trouble logging in, in the first place. It says can’t connect game to the launcher, but It is clearly connected in all ways. I click log out and it takes me to the sign in screen. I sign in with my credentials no problem. I click on any official server and join.

When I get logged into the official server, it spawns me under the map and no camera controls work. When I spawn in a car it gives me normal controls back but things are not normal. No one can see me. or have physical interaction with me. Its like I’m not there. They can see my chat messages. Also I can see the player count and stuff when I spawn in.

I’ve reinstalled BeamMP and the game multiple times. Ran everything as admin. Turned off my AV. And a few other things. I have been at a loss for months without BeamMP. I love BeamNG and play it A LOT. It would be nice if I could help with this problem.

Does it have anything to do with discord?
Sure I haven’t play it while running discord in my laptop. After I tried with discord running in the background it still wont work at all, the problem still the same as before. I’ve reinstall it using my friends steam account and the problem appeared the same. But when I try to login my beammp account and steam account on my friends device it magically works. I still have no idea why it happen but I’m sure there must be some device settings problem…

That’s the exact same problem I had🥲

I don’t think it has to do with discord. I just tried to run it with and without discord running, with the same problem. My problem is easily repeatable if anyone has a solution for troubleshooting.

i have the exactly the same problem.

Maybe you should try one of these solution:

  1. create another user on you PC, using local account instead of microsoft one is recommended, then install beamng from steam on that new user then try to play it using beammp.

  2. reinstall everything, including windows. reinstall windows will delete all installed aplication in that drive/partition of your disk but there are option to also remove the data/files or keep them. its recommended to back up your important files and data to prevent any unwanted error.

I’m actually not even try using the first method and just straight to second one. What I did is just reinstall my windows while keeping my files on the same partition as my windows. yes, it uses a lot of storage spaces because basicly you add new windows OS on top of the previous one. your data will be save inside of “windows.old” folder (at least, in my case). maybe you guys should give it a try…