Issues with Local Server

Setup a local Ubuntu Beam MP Server that I was playing with. Initially, I added the Roane, TN map and a bunch of other car mods and was able to play the game fine.

Since then I have removed the TN map and tried several other maps, all of which add me to the server and immediately kick me and my son that I play t he game with immediately. I even added the TN map back in as a test and I still get kicked out. I saw there was an update for the game, so I updated it.

Right now, no matter what map I add into the game, as soon as I try to connect Im getting Larger than allowed TCP packet received
Invalid packet: expected 4, got 3
died on Identification:168

Im in the discord channel, and I am a patreon to BeamMP. I didnt change a thing on my game or my PC, so no clue what is going on. Im hoping the initial kicked out was due to needing an update, but I cant get passed this error to find out.

Any help is appreciated. I’ve also removed every car mod I put in as a test and it hasnt helped.

I’ve done that for the maps…I entered the right name in the Server.cfg. And it happens for every map I try.

check out this forum post on maps

Thank you!! I got things loaded and connected…but now I get connected and immediately connection terminated

when you get the new server version, just replace the server.exe (or however linux works)

I didnt know you had to update the server files as well…do I need to bring the new .exe in and run it like a new install?

do you have the updated server version?