I've tried everything in the tutorial and the installation instructions

but I still can’t get BeamMp to work. As others have said it shows up on the main BeamNG Drive screen but when I click on it it just “boops”. If I try to reload the game using F5 or CTRL+L the icon is gone.

I’ve checked the BeamMP folder in the mods section of the BeamNGDrive folder and there is nothing there,

I’m computer and tech literate but I’m pulling out my graying hair trying to get this thing to work.

Any suggestions, and, yes, I’ve tried reinstalling BeamMP a few times and downloaded the newest version.

You can try this to see if it solves your issue

  1. Run the BeamMP launcher as administrator
  2. Go to the main menu
  3. Go into the Repository
  4. Click on Mod Manager
  5. Click on “Disable all mods”
  6. Then only enable the “beammp” mod (the BeamMP mod should be the only mod in your mod manager that is active
  7. Press Ctrl + L (if this doesnt work also press f5)
  8. If the BeamMP mod is the only mod active and you STILL dont see multiplayer, try restarting your PC and trying steps 5-7 (edited)

I’ve tried that, numerous times. The only problem is that BeamMP doesn’t show up as a mod in the Repository.

As mentioned earlier the BeamMP folder in the BeamNGDrive mods folder in the APP/DATA/Local folder is empty.

I believe this is where the problem is located and the question is what files are supposed to be there and where else they could be located or how to acquire said files.

Also, the BeamMP launcher keeps saying the “Game is newer than expected.”

“Game is newer then expected” is normal
Everytime the launcher is launched, it loads the mod into the correct file (which you should find by right clicking the beammp shortcut and clicking “open file location”)

Okay, I’ve done everything that was suggested and BeanMP still doesn’t show up in the Repository, so disabling all mods and enabling just that one won’t work.

I’ve located where the BeamMP files are located and they’re in the APPDATA/Roaming folder.

I’m just about to give up and forget about playing BeamMP as much as I would like to.

Of course, if there is anyone in the South Jersey/Philly area that wants to stop by and help you are more than welcome to do so. :slight_smile:

Join the BeamMP discord and ask for help in the support section, from there I can get on a call with you and help

UPDATE: Charles and I spent about a half-hour via voice chat and me sharing my screen to determine the problem and nothing seemed to work. I even disabled my virus scanner and firewall and no luck. I even gave BeamMP trusted permissions on my firewall and nada. We did get BeamNG to recognize that the mod was there but when I clicked on the icon the mod failed to see any servers.

It seems that there is something internal to my computer or OS that is blocking BeamMP from loading the mod into the proper folder.

For the record, I’m running a Windows 10 machine and every other program I have runs fine, even those on Steam.

As I told Charles, I want BeamMP installed so I can stream more interesting content than me just running from the police or playing the police by myself.