Mods from servers are not downloading

When I join a server that has any mods on the server my game does not download them so I can’t use any of the mods. My BeamNG user folder is in a different place than default so is that the issue? I have tried reinstalling BeaMP but it doesn’t do anything. The only mod that is in my mod folder is the BeamMP mod.


Hi @anime4life,

First of all that should not be the issue due the not using its default location. The whole idea of the launcher is it will only take use of the base of the game.

You should not want it any otherway, this will mean everyone could have some other mod on their end what will cause for everyone else an complete different thing.

Did you already tried to reproduce it with any other server jet so far ?

I have tried it with 2 servers that are owned by the same people and they don’t have many mods. They both have a very small mod that has always worked but it stopped working at some point a while ago and today I joined the other server that had a car mod that did not download either. I can try to join a server that is owned by an entirely different person if that could lead to something.


Hmm, really sounds so far to me its like missing from server at some point due it was working before. But I highly recommand you to proceed with testing just any other server with some mods at all to exclude things from either working or not.

Continuing from here will only be easier :wink:

I got the issue fixed by changing my BeamNG user folder back to the default location. It seems like the issue was that the BeamMP program doesn’t know where the mod folder is because when I reinstalled it, it didn’t even install the BeamMP mod itself. I hope this gets fixed because my C drive is not big enough to hande a ton of mods

If I recall correctly, BeamMP will create the Resources folder where BeamMP-Launcher.exe is located.
If you want to try, reinstall BeamMP to your desired location and check.