Mods won't reactivate after clicking "activate all mods" and gets stuck on the loading screen (please help)

Game has the latest update, mods were literally working a few hours before BeamMP messed up my whole game after attempting to join a server. After opening the game again, all my mods were deactivaed in the mod manager for no reason. The “activate all mods” button doesn’t work and gets stuck in a infinite loading loop. I’ve tried reinstalling the game already and it still gets stuck loading when I click on “activate all mods” and then throws a red Lua error message. I’m using over 300 mods but they are all from the repository and up to date. Like I had mentioned before, everything was working fine until I tried joining a beamMP server which deactivated my mods for no reason and now I can’t get them to activate again.

BeamMP deactivates all mods because client side mods are not useable in servers, it also needs to be the only active mod when you are playing BeamMP to avoid conflicts.

Red LUA errors are actually normal, I don’t know why, but they are. We all get a ton of them when launching the game, how you’ve avoided them up to this point I don’t know.

As for your mods not reactivating I can only assume that one or more of your mods are broken or not supported anymore and prior to being deactivated it was working only due to hopes and dreams of a better tomorrow.

Here are a few things you can try.

-Verify your Steam file integrity, any damaged or corrupted files should be replaced during this process.

-Activate your mods one at a time, it is quite possible that either your system or the game just can’t activate that many mods at the same time.

-Delete mods you no longer use, 300 mods might be needling the game engine to death, that’s quite a few more than recommended.

-clear your mod folder manually and then redownload all your mods, maybe there are broken files.

Keep in mind that any time you enter BeamMP your mods will be disabled automatically, I highly recommend getting rid of some mods.

Let us know how these troubleshooting steps go!