My client just doesn't work

There’s no place to login to. The multiplayer button doesn’t appear. I get the warning in the launcher “Game is newer than recommended, multiplayer may not work as intended!” Then the game loads and nothing. I have the mod activated in the repository and I’ve tried reinstalling and repairing and i give up i hope this is a problem you guys can fix in a future update because its not fixable by me :stuck_out_tongue:

1 Like

What do you mean with “There’s no place to login to.”? You have to click Play > Multiplayer then the login window will appear.

Once the game launches I click play but there is no multiplayer option to select it’s just the usual map selection screen.

I’ve been messing around more and my when i launch it says the mod has been duplicated somehow but ive reinstalled beammp and beamng drive, same thing so i tried looking for this duplicated file, when you pack beammp in the repository it creates a duplicate; but when i unpack theres the error “mod needs to be packed to update”. This really feels like a deadend.

I should add it automatically creates a duplicate beammp file on launching

Anyone know how to fix? Just wanna play with the homies.

Ty Power on disc For anyone else having this problem go through this checklist:
-You can ignore the Game is newer than recommended warning
-All mods except beammp disabled?
if its not disable, disable all of it except beammp and then press CTRL+L and then F5
-tried Unpack and Pack it again then press CTRL+L then F5?
-Tried Running it as Admin?
-Make Sure No AntiVirus blocking the Beammp

1 Like

Hi there,
Thanks for posting your solution(s), much appreciated :slight_smile:


1 Like