New update not working

i installed the new beem ng update in steam and now beemMP wont work

6 Likes

i have the same issue i think the new update broke beammp so we will have to wait for a fix unfortunately

1 Like

Check the “mods” option, and enable all

1 Like

it wont let me join my brother in the same server i join in says he left but on his it has him on the on player list and me bust not on mine just says me in server and cant see each other

BeamMP should have been updated to work with 0.24. Please update the mod and clear the game cache.
It’s advisable to disable other unnecessary mods as they are most likely not supported by the latest game version and may cause issues.

they must have just fixed it recently, its working for me now :smile:

It is still not working for me. How you manage to make it work? I cant see my friend in the server or direct connect.
If somebody know how to fix please advice asap :slight_smile:

1 Like

Same issue here. The login buttons unfortunately do not work. Even trying guest mode wont work and the name box is still visible no matter how much i try to enter. :confused:

REACTIVATE MODS beamngmp is considered a mod

REACTIVATE YOUR MIND, it is considered not working…

how do i update the beammp?

works for me scrub

relaunch as admin it should look for updates or re download

ok, here is how i got mine to work, i had to delete beammp, then i ran the game in safe mode, to do that, open the game with steam, and when the prompt shows up and says something like what would you like to do, there are three boxes, the first one being “run just to enjoy beamng” click the bottom one “support tools” then, the second option down says Safe Mode, click that and it will run the game, after that, go into repository and unsubscribe to the mod named BeamMP, or multiplayer, and then reinstall beammp on your computer and then run it like normal and then it should work again, this is what i had to do to get mine to work, im sorry if it doesnt for you but i hope this helps :wink:

The latest update is now fully supported, please relaunch BeamMP to dowload the update.
//Topic closed.