Other people cannot connect

I got a server going today but other people cannot connect to it and it doesn’t show that anyone tried to connect to it.

Hi,
Please ensure you have followed all steps necessary to set-up a server. It could be a port-forwarding issue, what does the server console say when it’s up and running?

When I connect it’s fine say’s that I have connected and give me an ID No. etc. but if someone else tries yo join they can’t but not sure if they’re getting any error codes because the one guy that tried wouldn’t tell me if he was getting any error code or not and doesn’t say if anyone has tried to connect.

[17/7/2021 16:26:04] [INFO] BeamMP Server v2.1.3
[17/7/2021 16:26:04] [INFO] Loaded 8 Mods
[17/7/2021 16:26:04] [INFO] Vehicle data network online on port 30814 with a Max of 5 Clients
[17/7/2021 16:26:04] [INFO] Vehicle event network online
[17/7/2021 16:26:04] [INFO] Lua system online
[17/7/2021 16:26:04] [INFO] PPSMonitor starting
[17/7/2021 16:26:09] [INFO] Authenticated!
[17/7/2021 17:22:04] [INFO] Identifying new client…
[17/7/2021 17:22:05] [INFO] Identification success
[17/7/2021 17:22:05] [INFO] Client connected
[17/7/2021 17:22:05] [INFO] Assigned ID 0 to Miles
[17/7/2021 17:22:17] [INFO] Miles : Connected
[17/7/2021 17:22:18] [INFO] Miles Connection Terminated
[17/7/2021 17:30:52] [INFO] Identifying new client…
[17/7/2021 17:30:52] [INFO] Identification success
[17/7/2021 17:30:52] [INFO] Client connected
[17/7/2021 17:30:52] [INFO] Assigned ID 0 to Miles
[17/7/2021 17:31:09] [INFO] Miles : Connected
[17/7/2021 17:31:22] [INFO] Miles is now synced!
[17/7/2021 17:38:00] [INFO] Miles Connection Terminated

That’s the whole log.

Odd - you have definitely port-forwarded?

Yes, unless I’ve done it wrong. All I know is that one part of it is 30814. Never really messed with port forwarding before.

When I tried to connect as normal, just says loading and fails to connect and doesn’t say anything on the log. The only way I can connect is by direct connect.


This is through direct connect.

Are you on discord? I can try and troubleshoot this with you

Well thanks for your help so far, but I got it sorted. I had to allow the ports through my firewall for some reason. It wasn’t happy with having the server allowed through, so had to have the ports as well lol. Thanks again though.

Glad to hear you got it sorted - Windows firewall can be a bit tricky some times, it rarely blocks the connection, but sometimes it can.

Happy gaming,
Dave