Port Forwarding Issue

Hello, I know that you guys have answered probably hundreds of port forwarding questions at this point, but I cannot think of anything else to do. In short, I’m trying to host a server, but the port that I have forwarded (the default 30814) doesn’t seem to open no matter what I do. I know that it’s a port forwarding issue since anyone who tries to join gets either the error codes 10060 or 10061.

The things I have tried are:

  • Confirming I have a static IPv4 address
  • Allowing inbound connections though my Windows Firewall using port 30814
  • Using different ports
  • Confirming my ISP allows port-forwarding (it does)
  • Using a port checker
  • Reinstalling the server client
  • Checking the forum for other topics to see if anyone else already solved it

I’ve port forwarded for other games before and had no problem until now. Like I said, I know this isn’t the first port forwarding related question here, so I’m trying to be as detailed as possible with my question. Thanks for your help in advance!

Just to make sure, you have used a port checker, and your port is open?
If your port is open with the port checker then it is something on the people trying to connect that is no allowing them to join, if the port checker is closed, then you didnt port forward correctly NOTE when using a port checker, you have to make sure that the port you are checking is being use. So when checking the port 30814, make sure that your server is running while you use the port checker :slight_smile:

I’ve used a port checker while the server is running and it says that the port is closed, so I know that there is a problem with how I port forwarded and not something wrong with anyone trying to join. I’m sure there’s something very simple I forgot to do that I just can’t think of, but I’ve double checked everything and followed multiple tutorials but no dice.

Make sure that you are port forwarding the correct internal IP (the internal IP of the computer running the server) For Ex.

make sure that TCP and UDP are both forwarded

check to make sure port forwarding is turned on, sometimes there is a toggle switch

I’m using the correct internal IP, I double checked it through both my router settings and through Command Prompt. Both TCP and UDP protocols are enabled, and the rule is toggled on (which I could honestly see why many people would forget to do that). I also just enabled DMZ just to see if it helps but the port is still closed with the server running. I even double checked if the ServerConfig.toml file changed the port on me for some reason but everything in that file seems to be correct (which shouldn’t matter because the console states that the server is running on port 30814 anyway).

By any chance are you using Comcast Xfinity?

No I’m using Linksys, sorry

I found the solution! It was my antivirus that was preventing anything inbound REGARDLESS of what rules I stated in my Firewall. For anyone else reading this, make sure to also check your antivirus if it has a built in firewall itself. And thank you so much Charles for your help!

1 Like