Problems connecting to BeamMP server

Hi All,
Recently got into this game and absolutely love it. I am trying to run my own server for myself and 2 or 3 of my friends. I have the server setup, and I can join my own server running on the same PC via direct connect with my IP. I have set up NAT/port forwarding on the default port in my router. However nobody outside my network is having success connecting to the server either directly via IP/ port or via server browser. Are there any other settings that need be changed in order to get this to work? Thank you.

We’re partnered with Modern Solutions for VPS’ that have BeamMP Server free install, if you can’t get through on the ISP side, might be a route for you.

Best Regards,
Holyguaka [IRL]

@holyguaka-irl At this point I’m thinking that may be the issue. I have tried pretty much everything I can think of and what my brother in law who works in IT can think of… still no dice. If I can get on the discord server at a reasonable hour I’ll go that route next.

Your ISP may also have blocked port forwarding,
I would advise that you call them back and just double check that they are infact allowing port forwarding.

Best Regards,
Holyguaka [IRL]

@lionkor Thanks, I may just do that. I only have one router, and the default 30814 is forwarded. I’ve contacted my ISP and converted to a static IP, but the port still shows as closed when I check it VIA a port checker website with the server running. I have a few more things to try but then I think that will be my next step.

@jstarr427 Could also be your firewall, or, if you have 2 routers, that will be the issue. If you need someone to help you with this live, feel free to hop on the discord server

@lionkor Thank you, I wasn’t sure which IP they needed to connect to. Tried tonight again with a friend, and no luck even with the ‘public’ IP from the website. I’ll be calling my ISP tomorrow to see if they have any more info. Thank’s for the help so far!

If someone else wants to connect to your server, they have to use your ip (like from the website you linked).

When I setup the router I believe it was set to forward both protocols. however, I am just now realizing that It could be that I am direct connecting to my server running on the same PC using the IP that my router assigns to it on the network (IE not the IP that is given if i go to Maybe that has something to do with it?


make sure you have the port forwarded as both UDP & TCP. Further, your ISP might be blocking it, in which case you should call them.