Queue system OR ImGui memory leak?

Good day! :partying_face:

0xC0000409 STATUS_STACK_BUFFER_OVERRUN is the error code I got, out of all things, actually after playing some BeamMP (I’m a new user, hello everybody!). You know how a memory leak does, it worsens over time, until it reaches a point where it makes your game so unstable, your game crashes. Also, with all of this I’ve also discovered a strange floating bug, a generic 0xC0000001, upon spawning some vanilla (!) vehicles - not important, however, I could fix this with a deep cache cleaning, nevertheless, my point is that none of this ever happened before on my end in vanilla (W10, AMD, Vulkan-less). Well, at least it’s not a Memory Access Violation. So, here’s why I think there’s an issue with specifically the BeamMP. :scream:

Steps to reproduce:

  1. Set MP options thusly:
  • Automatically apply queued vehicle changes = OFF :shushing_face:
  • Queue apply speed threshold = 0 km/h :sleeping:
  • Queue apply timeout = 20s :yawning_face:
  • Disable switching to other players vehicles = ON :face_with_raised_eyebrow:
  • Enable blobs for unspawned vehicles = OFF :ghost:
    (Basically I have set it up so that I don’t render player’s vehicles)
  1. Let people join AND queue in their vehicles. This shouldn’t cause any lag at all. But just to be sure, try idling for a few minutes. Even beyond the threshold, nothing should spawn anyway.
    (Now, if it doesn’t crash here in the next 5 to 10 minutes, then it’s gotta be the next step)

  2. Remove MP UI apps, such as the titlebar, chat and the playerlist. To replace the old chat, turn on the “New chat menu” back at the settings. The new ImGui chat should now appear on the screen (if it doesn’t, bring up the console first with ~ key).
    (You might also catch another ridiculous floating bug DUE to this, where as soon as players queue anything in, your camera sticks in one place, being not able to move or switch cameras OR vehicles, since they don’t exist, and you cannot respawn. At this point, you have done everything wrong as I did, and you will get a memory leak momentarily)

It was fun sim racing with you guys, really, but now I cannot play at all! I know I should try, for example, reinstalling BeamMP itself, or the config to undo my silly changes in hopes to get more FPS, but I want to take a break. I’ve driven an endurance Nürburgring 24 hours just about a few days ago, and I think I have already stress-tested everything, the server, my computer, myself. I met some nice people along the way, too! :clown_face:

Many thanks, take care, be well and big ups! <3

Good day! :grin:

Reinstalling BeamNG and BeamMP helped. They really did appear to be floating bugs! Try to have your mod count less than a hundred. :joy: :joy:

However, one bug persists. If one deletes the “Multiplayer Session” UI app on top of the screen, every queue event will make your camera freeze outside of your car, unable to do anything. :cry:

Having tested this multiplayer mod a bit longer now I think I can give you suggestions and feedback! :face_with_monocle:

Drive safe and be well! <3

EDIT: I think the “0xC0000409 STATUS_STACK_BUFFER_OVERRUN” error could be related to UI Vehicle Mirrors mod, seen below. It creates memory leaks with the Dear ImGui chat.

I think you described the issue I posted yesterday. I have Windows 10, AMD GPU and 32GB of memory and it seems like after some Windows Updates, BeamMP leaks memory.

So I think I fixed my problem in the following steps:

  • Delete BeamMP mod in the game
  • Check which Windows Updates were installed between the time the game worked and not worked on BeamMP.
  • Uninstall all Windows Updates from that time.
  • Reinstall BeamMP

I did it and worked. But before managed to solve, I tried clean reinstall of GPU driver (with AMD CleanUp Tool) and verified the game for errors (option from Steam).

I think Windows Update of .Net Framework is what cause the problem, but it is really more a feeling than a fact.

Hope to see you in the game again. See ya!

1 Like