Server Deleting config file

here is the error I am getting:

:/home/container$ ./BeamMP-Server
[18/11/22 19:20:50] [INFO] BeamMP Server v3.1.0
[18/11/22 19:20:50] [ERROR] Error parsing config file value: [error] toml::parse_key_value_pair: missing value after key-value separator ‘=’
→ ServerConfig.toml
28 | MaxPlayers =
| ^— expected value, but got nothing

I am putting the stuff its asking for in the config but it just deletes it.

Hello @AlternateFunction4 ,

Please could you upload your ServerConfig.toml to here using the preformatted text option.

This can be done by pressing CTRL + E and then pasting the content into there. Please ensure you remove your server key from your message before posting.

Kind regards


# This is the BeamMP-Server config file.
# Help & Documentation: ``
# IMPORTANT: Fill in the AuthKey with the key you got from `` on the left under "Keys"

# Enables the internal HTTP server
HTTPServerEnabled = false
# Recommended to have enabled for servers which face the internet. With SSL the server will serve https and requires valid key and cert files
UseSSL = false
# Which IP to listen on. Pick for a public-facing server with no specific IP, and or 'localhost' for a local server.
HTTPServerIP = ""
HTTPServerPort = 8080
SSLCertPath = "./.ssl/HttpServer/cert.pem"
SSLKeyPath = "./.ssl/HttpServer/key.pem"

# If SendErrors is `true`, the server will send helpful info about crashes and other issues back to the BeamMP developers. This info may include your config, who is on your server at the time of the error, and similar general information. This kind of data is vital in helping us diagnose and fix issues faster. This has no impact on server performance. You can opt-out of this system by setting this to `false`
SendErrorsShowMessage = true
# You can turn on/off the SendErrors message you get on startup here
SendErrors = true
# Hides the periodic update message which notifies you of a new server version. You should really keep this on and always update as soon as possible. For more information visit An update message will always appear at startup regardless.
ImScaredOfUpdates = false

Description = "east coast usa bhost"
ResourceFolder = "Resources"
Map = "/levels/east_coast_usa/info.json"
MaxPlayers = 10
Port = 30814
Private = false
Debug = false
Name = "east coast usa bhost"
# Whether to log chat messages in the console / log
LogChat = true
MaxCars = 3
# AuthKey has to be filled out in order to run the server
AuthKey = ""

@LionKor thoughts as this looks okay to me.

Please update to v3.1.1

do I just delete the BeamMP-Server file and install the new one?

after updating that file this is what I got:
[Pterodactyl Daemon]: Finished pulling Docker container image
:/home/container$ ./BeamMP-Server
/ line 13: ./BeamMP-Server: Permission denied

that might be a problem with my panel, I’m using Pterodactl panel

You will need to do chmod +x BeamMP-Server

But, its true that the panel might cause issues.

it says: chmod: cannot access ‘BeamMP-Server’: No such file or directory

I found out how to make that work and now it has perms but it says: cannot execute binary file: Exec format error

I think I was using a modified version that runs on ARM cpus so I might have to wait for a new ARM version to come out.

Hi! For ARM, you have to compile the server yourself. Instructions for this are on the github.