The server files still do not work

Ok, so about 9 days ago I made a post about how my server wouldn’t work and it said connection failed in the same post I said that the server didn’t work for my friend either and I got a reply from an admin by the name Charles saying they were gonna check it out with the developers and see where the problem is since then I made a new post where I asked if the issue had been fixed and I got a reply from anonymous275 saying it had been and told me to download the server files again so I tried to make a new server and it still didn’t work and about a couple of minutes ago I noticed the same issue getting reported by King reaper official and he got a different reply from either of the ones I got but he hasn’t replied yet so I don’t know if that worked.

@themonsterbull Can you confirm if your issue is resolved?

Holyguaka [IRL]

Every router is different, from what I can gather, exposed host is another term for DMZ which means it will open all ports to one device. This would work, but for safety reasons it is not smart to open and allow all ports open on your router.

do i need to enable exposed host in my router settings?

Make sure you have port forwarded correctly in some cases it’s impossible to port forward and you have to use 3rd party software to host a server. The evidence is clear as day the connection never reaches the server suggesting an outside blocking force could also be the firewall.

I will push this thread to one of our staff members who can help.
Our apologies for the lack of communication @themonsterbull

Best Regards,
Holyguaka [IRL]

Hi, I have same problem… is here some solution?

actually i get a error code in the beammp console but not in the server console
[5/1/2021 14:06:37] [INFO] Launcher version is up to date
[5/1/2021 14:06:37] [INFO] Game Version :
[5/1/2021 14:06:37] [INFO] Downloading mod…
Progress : [ 100% ] [##########################]
[5/1/2021 14:06:39] [INFO] Download Complete!
[5/1/2021 14:06:39] [INFO] Game Launched!
[5/1/2021 14:06:58] [INFO] Game Connected!
[5/1/2021 14:06:58] [WARN] Game Reconnecting…
[5/1/2021 14:06:59] [INFO] Game Connected!
[5/1/2021 14:07:19] [INFO] Connecting to server
Client: connect failed! Error code: 10060

sorry for the late response i was away from my computer at the time but, no I am not getting any errors in the console when i try to connect and it says connection failed as you can see here
[5/1/2021 14:06:24] [INFO] BeamMP Server Running version 1.20
[5/1/2021 14:06:24] [INFO] Config found updating values
[5/1/2021 14:06:24] [INFO] Lua system online
[5/1/2021 14:06:24] [INFO] Vehicle data network online on port 30814 with a Max of 2 Clients
[5/1/2021 14:06:24] [INFO] Vehicle event network online
[5/1/2021 14:06:24] [INFO] Server authenticated

Hello, that is correct. Any error messages in the console, or an error code?