Tried redownloading Beammp because its not working, but it wont start

Whenever i try to start it up after redownloading it, it says:

“the item ‘Beammp-Launcher.exe’ that this shortcut refers to has been changed or moved, so this shortcut will not longer work properly”

Does anyone know what this means or how i could fix it?

You moved the install location for BeamMP, the icon on your desktop is still connected to the old file pathway. This might be due to a version change depending on how long it has been since you played beam (for example if the 0.31 folder is now 0.32). Please delete your desktop shortcut, use the windows search feature to find BeamMP’s launcher, right click it and hit “create shortcut.” This will pop a new shortcut up on your desktop that is connected to the new file pathway.

Hey, sorry for the late reply. I did what you said and beammp opened for me, but whenever it opens the multiplayer button is not there.

Your version of BeamMP might be bugged go into single player and delete the Mulitplayer Mod from your repository, then launch the game through the BeamMP Launcher to redownload the mod in its newest iteration.

I did this, but whenever I tried to open up beammp the black page thing opened up for a couple seconds, then disappeared and nothing happened. I deleted and reinstalled beammp but it is back to doing the “this shortcut has been moved” thing, even after i did the create shortcut thing

Ok, so i was able to get it to work again, but now its back doing the thing where the button for multiplayer does not show up in the UI. How could fix this?

Hello, try now, the new BeamNG Drive update absolutely rocked our socks, the big brain programming people on the team have since fixed it and redownloading the mod should net you an updated version.

Thank you! The game is working well now.

Nice! I’ll go ahead and tag this one as solved.

1 Like