[WARN] Back end system refused

Hi all

I’m having an issue a recently purchased a server from fluorite.gg for beam ng upon payment the server automatically sets itself up, now the server boots and I personally can join it using direct connect but I cannot see it on the server list

The command line keeps showing the issue

[WARN]Back end system refused your server may not appear in public server list!

There is no code or error message apart from this

Does anyone have any ideas how to solve this ?

Hello @Scouseladchris Thank for for taking an interesting in our mod!

Unfortunately I will be limited in what help I can offer you as Fluorite is not one of our hosting partners.
As for your issue it could be for several reasons. Can you provide any of the other log entries / lines on the console around this error?
Equally you can enable debug mode on the server assuming they give you access to that and it will help us to figure why you are getting this error.

Thanks
~Titch

Hi Titch thanks for the reply this is what i get upon booting the server

[email protected]~ Server marked as offline…
[Pterodactyl Daemon]: Checking server disk space usage, this could take a few seconds…
[Pterodactyl Daemon]: Updating process configuration files…
[Pterodactyl Daemon]: Ensuring file permissions are set correctly, this could take a few seconds…
[email protected]~ Server marked as starting…
[Pterodactyl Daemon]: Pulling Docker container image, this could take a few minutes to complete…
[Pterodactyl Daemon]: Finished pulling Docker container image
:/home/container$ ./BeamMP-Server
[4/12/2021 15:02:52] [INFO] BeamMP Server v2.0.3
[4/12/2021 15:02:52] [INFO] Config found updating values
[4/12/2021 15:02:52] [INFO] Loaded 9 Mods
[4/12/2021 15:02:52] [INFO] Vehicle event network online
[email protected]~ Server marked as running…
[4/12/2021 15:02:52] [INFO] Vehicle data network online on port 27132 with a Max of 6 Clients
[4/12/2021 15:02:52] [INFO] Lua system online
[4/12/2021 15:02:52] [INFO] PPSMonitor starting
[4/12/2021 15:04:59] [WARN] Backend system refused server! Server might not show in the public list

this is what i get back with debug activated

[Pterodactyl Daemon]: Checking server disk space usage, this could take a few seconds…
[Pterodactyl Daemon]: Updating process configuration files…
[Pterodactyl Daemon]: Ensuring file permissions are set correctly, this could take a few seconds…
[email protected]~ Server marked as starting…
[Pterodactyl Daemon]: Pulling Docker container image, this could take a few minutes to complete…
[Pterodactyl Daemon]: Finished pulling Docker container image
:/home/container$ ./BeamMP-Server
[4/12/2021 15:09:23] [INFO] BeamMP Server v2.0.3
[4/12/2021 15:09:23] [INFO] Config found updating values
[4/12/2021 15:09:23] [DEBUG] Debug : true
[4/12/2021 15:09:23] [DEBUG] Private : false
[4/12/2021 15:09:23] [DEBUG] Port : 27132
[4/12/2021 15:09:23] [DEBUG] Max Cars : 1
[4/12/2021 15:09:23] [DEBUG] MaxPlayers : 6
[4/12/2021 15:09:23] [DEBUG] MapName : “/levels/east_coast_usa/info.json”
[4/12/2021 15:09:23] [DEBUG] ServerName : “Abyss Roleplay Community / Custom Cars & Economy / Fluorite.GG”
[4/12/2021 15:09:23] [DEBUG] ServerDesc : “Abyss Roleplay Community Visit Fluorite.gg For Server Rentals! Custom Cars & Economy | File Manager”
[4/12/2021 15:09:23] [DEBUG] File : “Resources”
[4/12/2021 15:09:23] [DEBUG] Key length : 36
[4/12/2021 15:09:23] Main [INFO] Loaded 9 Mods
[4/12/2021 15:09:23] TCPServer [INFO] Vehicle event network online
[4/12/2021 15:09:23] UDPServer [INFO] Vehicle data network online on port 27132 with a Max of 6 Clients
[email protected]~ Server marked as running…
[4/12/2021 15:09:23] LuaEngine [INFO] Lua system online
[4/12/2021 15:09:23] PPSMonitor [INFO] PPSMonitor starting
[4/12/2021 15:11:29] Heartbeat [WARN] Backend system refused server! Server might not show in the public list
[4/12/2021 15:11:29] Heartbeat [DEBUG] server returned "

504 Gateway Time-out

504 Gateway Time-out


nginx/1.19.7 "

did you go through the setup ? because you need a key to show up in the list

Yeah I have a key set up in the server configuration file so should all be correct

@LionKor could you advise as to which response from the backend causes this output.

The occasional 504 Gateway timeout is due to our system messing up. It is in the process of being fixed though.

Hi,

This is, indeed, a 504. @Scouseladchris you can ignore this if it happens again.

Generally, when something is really wrong, it will say this kind of message every 30 seconds. If it only says it once, then it’s not an issue and likely the 504 issue on our end.

Best of luck & enjoy the mod
~Lion

So still having issues still can’t see it on the list keep getting the same issue over and over again

Could you contact me on discord so that we can sit down in a call and go over the setup to locate the issue?