Error 10060 help please

[8/2/2022 12:05:24] [INFO] Launcher version is up to date
[8/2/2022 12:05:24] [INFO] Game Version : 0.24.1.1
[8/2/2022 12:05:24] [WARN] Game is newer than recommended, multiplayer may not work as intended!
[8/2/2022 12:05:24] [INFO] Downloading mod please wait…
Progress : [ 100% ] [##########################]
[8/2/2022 12:05:25] [INFO] Download Complete!
[8/2/2022 12:05:25] [INFO] Game Launched!
[8/2/2022 12:05:35] [INFO] Game Connected!
[8/2/2022 12:05:35] [WARN] Game Reconnecting…
[8/2/2022 12:05:35] [INFO] Game Connected!
[8/2/2022 12:06:33] [INFO] Connecting to server
[8/2/2022 12:06:54] [ERROR] Client: connect failed! Error code: 10060

Already answered here: I have problem
And also on our wiki: Error Codes & Meanings | BeamMP