No server list

So you launched the mod shortcut, the game loaded, but when you click ‘Play MP’ you don’t see any servers - very annoying!
Please follow the steps below to try and fix this issue:

  • Restart the launcher; (Most common fix!)
  • Run the launcher as admin;
  • Make sure the launcher is still running in background after the game has opened
  • Ensure that your antivirus software* isn’t blocking the connection; if it is, make an allowance for the app
  • Allow the app through windows firewall

*As of 25/10/2020 BitDefender, Norton and G Data have been reported to block the app from running correctly, even if it doesn’t explicitly say there is an issue!! Disable or remove this antivirus, then try the app. If it works, try and make an exception for it in the software.

This is not a particually common issue, so if you have found other fixes, please feel free to share them below!

I was able to fix someones issue just now by opening steam and check for updates before he updated his BeamNG game on steam he did not have the online icon at the top on the main menu.

If you have this issue try updating your game through steam.

1 Like

@napier41 Hi Napier- there have been issues with Norton blocking parts of the application from working, even if Norton says it isn’t. We’ve had a couple players solve the issue by removing Norton completely ; perhaps you could try this and then see if it works? If that allows multiplayer to work correctly, we’ve atleast narrowed it down to the AV.
Cheers, Dave

I’m having the same issue of no server list, I went into norton security and made sure that it wasn’t being blocked then tried to run as administrator. Doing both of these didn’t seem to fix the problem, I have also checked to see if beamNG needed an update through steam and it doesn’t. I just uninstalled it through the wizard and re-installed the application but doesn’t seem to change it. It all occured after I tried joining a server when I first downloaded the launcher, then when I closed and re-opened the application I had this issue. Any suggestions?

My problem is that the launcher never actually connects with my game and therefore no servers are visible and the refresh button does nothing. This only started occurring randomly after the most recent 0.24.1.1 update, multiplayer was working flawlessly up until this point for months. I use to get a “Game connected” message in the multiplayer launcher, but not it just says nothing after saying “Game launched”.

I reinstalled BeamNG and the launcher, still nothing.

Restarting the launcher as these instructions say, I assume without closing the game and allowing the launcher to reopen the game, doesn’t work, you just get an error saying it couldn’t bind to the game and the launcher closes.

Running the launcher as admin seems to do absolutely nothing and I just get the same exact results every time

The launcher is always running in the background still when the game opens, but it never says anything past “Game launched”

There is no antivirus software on my computer to block this, and the multiplayer worked for months, this seems to be something else besides nonexistent antivirus blocking the connection.

The app is indeed still allowed through the Windows Firewall, as it always has been.

What do I do now? Like I said, the multiplayer was working great, then suddenly it just doesn’t now seemingly because of the 0.24.1.1 update to BeamNG which, for basicially everyone else, works flawlessly with the multiplayer.

Check if you’ve changed the port on which the launcher connects to the game, 4444 by default, it’s under setting in the multiplayer menu, both the launcher config json and in-game one have be on the same one. If 4444 isn’t working out you could try a different one.

Other than that I have no idea why the update would break anything regarding that, it seems to working the same as before on my end.

Hey this got me somewhere, the menu in the game displayed a blank space instead of 4444, I clicked it and 4444 appeared, now on restart 4444 is there from the beginning and it appears it’s looking at that port as expected again, however the launcher still doesn’t ever say “game connected” and it’s as of nothing’s changed, my first thought was to go to that config.json file and set it to 4444, I found it however I couldn’t open it at first and then when I looked up how to and figured it out, when you open that file, it displays “{“tos” : true}” and absolutely nothing else. Is this supposed to have more in it? I don’t know how these files work obviously but logically I was expecting to see something along the lines of port : 4444 and be able to adjust that number in the file.