Please help me with this i keep getting error code 4

whenever i open the luancher it says Launcher version is up to date
[ERROR] Failed to find the game please launch it. Report this if the issue persists code 4 please help with this becuase im a youtuber and im doing a race in a beammp server please fix
does anyone now a fix???

2 Likes

managed to fix?

Am getting the same problem now?

Do you own the game?

my game just says

ive tried re installing game removing all mods i do use the launcher


ive tried logging out it wont let me

it says mine is not even connected to launcher

Good day! :dizzy_face:

It’s a known issue in many Windows software. :face_with_symbols_over_mouth:

Failed to find the game please launch it. Report this if the issue persists

Code 3 and 4 all lead to userfolder path or registry entry read failure ON WINDOWS, on linux it means something’s wrong with your pfx (which is as annoying as this, tl;dr don’t complicate things for yourself by jumping from one proton version to another, stick to 7 or 8 for now). No, despite what the mods or devs say it has NOTHING to do with ownership of the game or cracked copies or whatever, they work just fine, the problem lies somewhere else. Anyway, we’re gonna be working with the registry and it’s a bit scary.

When you change your Windows username (be it via migration, upgrade from Win7 to Win10/11 or you did so manually), the one that is in the C:\Users\username folder, or the fact that when you were installing Windows, you have set up your username with special characters (i.e. unicode) in it, THAT could have a MAJOR impact on how your computer reads and edits files, for example: ever wondered why some folder names are not allowed (< > : " / \ | ? *)? Well, Windows is NOTORIOUS for this (unlike in Linux or MacOS, which file systems support unicode out of the box, lmao), such as with Cyrillic, Japanese, Chinese character sets, etc. as well as ANY diacritics, including é, ü, ç and other charsets (fun read: mojibake). Back in the old days Windows had only ANSI charsets so it had just the latin letters, then came the UTF-8 and it introduced a bunch of problems that still linger to this day, but generally nowadays software IS written with support for unicode charsets, so that there will be no issues such as these. Unfortunately, neither BeamMP has this resolved yet, neither Microsoft has told anyone this, nor anywhere else in the world that you SHOULD NOT create a Windows username with non-latin characters. For example, even though computers in Asia use different encoding, in Japan all computers have only latin usernames in them, because otherwise there would be software issues, just like the one we are having. A similar problem was reported on BeamMP’s github. :sob:

Create a new local Windows account with just Latin characters. Install BeamNG and BeamMP using that new user account. It should hopefully work now. If the issue lies with your old AppData conflicts, then try this: :pensive:

open run, type regedit, go to

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders

and/or

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

and BACKUP (!!!) your registry first in case i just spread misinformation online, then change
Local AppData” file path entry with %USERPROFILE%\AppData\Local
(sic!) OR you could manually type in your new username instead of %USERPROFILE%

Well, and that’s it! Do you still enjoy using Windows? Yeah… no.

Be well! :heart: