RaceMP | A Racing Mod for BeamMP

I’ve written a racing mod, focused on one off races, instead of hotlapping. Some of the client side code was based off @Dudekahedron’s Hotlaps mod. To install and use RaceMP, follow the instructions linked below. In the TODO file are some future plans for the mod. Feel free to report bugs, make suggestions, etc here.



Hey nice project, and thank you for helping to grow the support and engagement by releasing your work!

Might I recommend adding some screenshots of it in-game?

Hey, love the idea of your resource, I tried using it and it loads but the commands dont send anything back in chat, not sure if its something im doing or not.

Sorry, I’ve been busy recently, it’s not quite working right now, position order is off. I’ll be working on it when I can.

Are you getting any errors server or client side? Client side would be in the console ( `/~ key by default). The server side should have a “RaceMP loaded” message on startup, and when a player loads into the server.

First of all, this mod is awesome and I really appreciate your effort! I can’t log in to your gittea, nor can I make an account. I wanted to open an issue there but I guess for now I will do it here.

The documentation and the server side script dont cohere with each other. In the documentation you say the syntax for setting the lapCount is /set lapCount=3 but on line 196 of the server side script it expects the key “laps” instead of lapCount (settings["lapCount"] = tonumber(args["laps"])).

You could change the documentation to say the key is “laps” or change the script to expect the key “lapCount” although I prefer the first.

I hope you fix the gittea login issue then I can contribute through the official channels. Again thanks for your contribution and work!

Interesting! RaceMP is kind of interesting!

Hello! I’ve installed this on my server, and although the commands and menu appear to be working, I’m not sure if the checkpoints and stuff are actually working, or what I’m supposed to be seeing when I start a race. A countdown appears in chat, and I can set the race name and track, but when I start the race I get a countdown and nothing happens after. It seems like the only tracks are multiplayer_race_short and long, I’m not sure if that’s correct. Some screenshots of the mod working properly would be appreciated.

Update: I figured it out, it’s actually quite impressive and works pretty well, I just wish we could see the checkpoints, as I’m sure not every player knows every scenario layout by heart. I’d especially like a way of seeing the starting line before the race start, so players can get lined up correctly, and a race cancel command. Other than that, this is a really great plugin that will allow competitive racing, which BeamMP really needed.

1 Like

Also, any chance we can get instructions/documentation on adding our own scenarios/races to this?

I am investigating and/or planning all of these things, the TODO file has most of what I’m planning. New job is wearing me out though, so it’ll be a little while before I sit down and work on it again.


Looking forward to it man, even with the small finish bug its proved a really great way to add some structure to BeamMP multiplayer sessions.

Hey, the link no longer works.

It works again.

I’ve been running this on my public server for a couple weeks now, and so far it’s great. There are only two major issues: is finish order, which can be kept track of via voice chat, the other being that It seems like after a few races, the race finish screen stops working, and the console fills with the same error over and over whenever a player hits a checkpoint. I’d paste it here, but I just did some maintenance on the server and I don’t have any players to reproduce it with, so I’ll come back next time it happens.

Here’s the log from that bug I mentioned.

[LUA ERROR] onLapSplit: [string “Resources/Server/RaceMP/RaceMP.lua”]:22: bad argument #1 to ‘pairs’ (table expected, got nil)
[17/06/23 15:49:43] [LUA ERROR] onLapSplit: [string “Resources/Server/RaceMP/RaceMP.lua”]:22: bad argument #1 to ‘pairs’ (table expected, got nil)
[17/06/23 15:49:58] [LUA ERROR] onLapSplit: [string “Resources/Server/RaceMP/RaceMP.lua”]:22: bad argument #1 to ‘pairs’ (table expected, got nil)
[17/06/23 15:50:15] [LUA ERROR] onLapSplit: [string “Resources/Server/RaceMP/RaceMP.lua”]:22: bad argument #1 to ‘pairs’ (table expected, got nil)
[17/06/23 15:50:15] [LUA ERROR] onLapSplit: [string “Resources/Server/RaceMP/RaceMP.lua”]:22: bad argument #1 to ‘pairs’ (table e

any new updates by chance

have you gotten this to work? i put it into my server and it had put up some type of a user interface but that was about it?

hey man so how do you get it to work exactly?

Hi just wondering if it was possibly to implement this into a map i use on multiplayer, also if there is a patreon to help fund this ?