Client failed to create directories

[FATAL] create_directories: unknown error: “C:\Users\ ?\AppData\Local\\0.31\mods/multiplayer”

hi there. beammp was unable to create a \multiplayer folder because the path to it doesnt exist. after c:\users\ should follow your local account user/home path. unless by accident please never do anything to your users folder, it’s pretty easy to completely brick your computer.

I did nothing to the users folder and the game is in default path, so im very confused about this…

The client somehow wants to create a folder with / instead of \

maybe create the folder manually?

i tried but it didnt work

what is your windows username after c:\users\ because unicode characters are shown as ??? marks, so certain programs cant work correctly. if you have them, i think the only way is to create a new local account, you can google how

i changed my user name into simple letters using administrator account ,and it continues showing me the same message :smiling_face_with_tear:

and you reinstalled beammp on that user? because it could store old data somewhere, hopefully NOT in the registry though…

have reinstalled multiple times, including other paths :melting_face:

so forbidden file and folder names are: < > : " / \ | ? * and you have a question mark because windows did an oopsie yay, it is an incredibly flawed system (so is beammp network code but that’s besides the point). anyway, we’re gonna visit the registry. open run, type regedit, go to HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders as well as HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders and BACKUP (!!!) your registry first in case i just spread misinformation online, then change “Local AppData” file path entry with %USERPROFILE%\AppData\Local OR you could manually type in your new username in the path. just to reassure, it’s not system data you’re editing, just some REAL paths that the windows can SEE. you will eventually have to repeat the process for every other entry, since you have been using a username that is incompatible in windows file paths.

edit: sorry fixed a typo, silly me. it’s run not cmd

client can launch the game now, but without multiplayer stuff XD
it created a multiplayer folder in the mod folder, but thats all it did
and this error occurs : [ERROR] HTTP Get failed on SSLConnection
i installed SSL certificate manually but nothing happend

edit: problem solved!! thank you so much for finding solution to this weird problem