Linux Setup BeamMP (Proton) with SteamTinkerLaunch

Hello everyone!

This is made in reference to a Github issue I opended “Unattended installer for Proton? #372
This small little guide is meant for PC users but can be used by SteamDeck users if steamtinkerlaunch is also available to you. This should work on any Distro.

You want to grab the latest release of the launcher only. No installer just the launcher. Ignore any pre-releases as these may not work as intended or be compatible with the current servers.

Then navigate to your game installation folder. Easily done as such if you do not know.
Click the game in the Library in Steam and enter Properties->Installed Files->Browse…

Place the Launcher.exe in there.
Make sure you have SteamTinkerLaunch installed.
You can find it here:

It is available for Flatpak and Native Steam on the most common distros.
In my case I use Fedora.
If you are new to steamtinkerlaunch there is the command:
steamtinkerlaunch --help to see all options.
But what you want is to have STL as selection as proton.

To do that for the first time on a native Steam installation you want to use the compat command in the terminal.
“steamtinkerlaunch compat add” and maybe also “get”. This will add SteamTinkerLaunch as proton option. It will be visible after you restart steam once. And the get command I think is used for STL to later have all proton options from Steam in its own options as selection.

In the Steam properties of the game again select Steam Tinker Launch under Compatibility.
Click run and then once you see the window go to the main menugame menu

You will want to set a custom command and tick the box.
The selection opens a explorer. Select the Launcher.exe you placed in the game folder.

After you did all that scroll carefully down (on the side otherwise you may rotate some options with scroll wheel).
At proton version you want to select the one you feel comfortable with. But the higher the number is the latest iteration and possibly the most benefits. But don’t be afraid to change to a other one should you have issues.

Hit Save and Play! The BeamMP Commandline should be visible.
And your Game should start like BeamMP was installed.
You may have to enable mods on the first launch in the bottom left before you see the Multiplayer option.

Once you quit the game you may be prompted with a second launch option. You should just close that.
SteamTinkerLaunch things the game may crashed but this warning can also be ignored.

Best Regards,


not working for me, anything I’m messing up on?

The CMD certainly should stay open.
I have to add I used Proton 8 stable.

I also want to refer to my Github issue:

I did try to run the installer previously without success
You can do it the same way and then have to change the launch to the .ink file which is created by the launcher in the compat. Also the Launcher itself can be found after the installer ran correctly inside the appdata of the compat.

I also did try:
STEAM_COMPAT_CLIENT_INSTALL_PATH=“/home/legion495/.local/share/Steam” STEAM_COMPAT_DATA_PATH=“/mnt/media/steam/SteamLibrary/steamapps/compatdata/284160/pfx” WINEPREFIX=$PWD “/mnt/media/steam/SteamLibrary/steamapps/common/Proton 8.0/proton” run ./drive_c/users/steamuser/Desktop/launcher.exe

Without much success.
But maybe one of those did change something?
It would surprise me.

Also the installer worked for me on Proton 3. something.
But obviously that did not help me in Proton 8.

Maybe you find why it is different.
Also maybe you use flatpak steam? I use native.

My venture started at that reddit:

Oh and also if you use Ubuntu it might a different issue altogether.
Ubuntu uses Steam Snap exclusively so that might also cause issues.

I have no experience with this specifically. I only know random games started to refuse launching.
I am not sure how that reacts to a changed exe with Proton. It is why I avoid Ubuntu now days.
Chances are someone at AskUbuntu would have a hunch on how to best handle it then.

Please let us know if any or none of those helped and if you got a guide on how you might solved it.
Also did you run it native first without STL? First time install trigger might also does some adjustments.
You should be able to force it with a file integrity check.

I want to thank you for your post, you solved my issue!
You are the best!

1 Like

It just crashes

I just want to thank you for this, I got this working on nix os, steamos, arch and nobara, not an official way but a super easy process since the script out there just doesn’t work, and there are other jank solutions. This works on the deck in the deck ui, with mods, decent framerate surprisingly on steam deck. And similar performance to windows 10

Specs:5950x, 64gb of 3600mhz, rtx 3090 on my nobara install or the ultrawide.

Steamdeck is just the 512gb haven’t tried sd performance. Was low but suprising

Let me know if you want my ge version but I didn’t have an issue with the latest about 1-2 weeks ago so.

Both of these were in carp didn’t get any top images but it felt good.

This definitely works and you should give it a try anyone just getting to this post.

Daniel [CO-US]
BeamMP Admin


Well as SteamTinkerLaunch tells you it cannot find the Proton version or none is selected. I would check there. Test it with other games too. Games that run will also run with STL default. You maybe only need to select the proton version.

Can you select the Proton version you see in Steam in the game menu of STL?

Flatpak Steam has a own SteamTinkerLaunch than native. In Gnome Software I can see addons for Flatpaks. SteamTinkerLaunch is part of this stuff for Flatpak.
I assume you have KDE. I am quite certain Discovery will also somewhere show Addons.

To me this looks like compat get was not run if native.
SteamTinkerLaunch should just reflect your Steam Protons.

You should first focus on getting any game to launch with STL to diagnose this.
Also you should let us know if it is Steam Flatpak or Native. Also the Distro helps.
This would go a long way to help and diagnose.
By chance you are new to that. In that case I strongly recommend to learn the difference of Flatpak and Native Apps. It helps a lot.

I fixed that now it does this

I also used the pacstall method of install tinkerlaunch and I use ubuntu if that helps

I’m using Ubuntu with the native Debian install of steam I used pacstall to install steamtinkerlaunch

Got it to start BeamMP’s Launcher, however it attempts to load BeamNG through steam, then freezes on “Waiting for game process”, is it trying to launch BeamNG through steam, which is set up to go through SteamTinkerLauncher?

Make sure you launched the game at least once in the proton you will use.
I suspect this creates entries in the prefix.

The prefix will load the game too and in this “virtual” Windows the Launcher should be able to launch the game directly like it would in Windows.
Steam will most likely only detect that the ProtonWrapper is running.

I can’t get it to work on Kubuntu

Please use the Steam DEB install and not the one from the Software Center.

One of Valve people posted that the Ubunut Snap distributed by the Ubuntu Software Center causes many issues.

You may further want to install Proton-Up via Flatpak to install SteamTinkerlaunch.

The Ubuntu Snap is not supported I think.

1 Like

Reinstalled steam and installed Proton-Up via Flatpak still same problem

What happens if you hit launch?
I assume the game has been run before and installed in the used Proton Prefix?

A first run may help if that causes issues.
I am currently not at home.

Same thing happens, yes I ran it before with the same proton

So I managed to run it but the latest Update seems to not be ready yet.

Using Proton 8.0.5

I fork the command because the cmd is unable to boot the game.
I set a delay to 10 seconds so the cmd is updated and ready when the game launches. You may need to play with that.

(Picture in next Post)
Then had to enable it in the mods section.
(Picture in next Post)
When I tried it was blocked because it isn’t updated yet.

I noticed you have your SteamTinkerLaunch set to Mod Manager.
I do not know if this will affect the game in any capacity.